Archiv für den Monat: Mai 2011

Joomla Problem gelöst dank Social Networking

Ja wer hätte das gedacht. Gestern poste ich noch voller Verzweiflung in meinen Blog und heute sitze ich schon da und schreibe die Lösung.  Ich hätte es selbst kaum geglaubt. Aber es ist tatsächlich so. Damit diejenigen unter euch, die wegen des Fehler hier sind, nicht den ganzen Text lesen müssen, hier erst mal die Lösung: Ich hatte ja gestern geschrieben, dass eine Kategorie liste im Multilingualen Blog  nicht mehr dargestellt wird. Der Link im Menü funktioniert einwandfrei. Auch die Kategorien werden angezeigt. Allerdings fehlt dann darunter die Auflistung der mit der Kategorie verbunden Artikel. Wenn euch das bekannt vorkommt dann habt ihr sicher auch gerade versucht Mehrsprachigkeit bei Joomla 1.6 einzustellen.

websitejoomla2Joomla 1.6 hat eine entscheidende Neuerung. Die Rechteverwaltung der Benutzer sowie der aller anderen Bestandteile. Man kann Unmengen zulassen und verhindern indem man das neue “Access Control System” voll ausschöpft. Genau das war der Grund warum ich dieses Problem hatte. In den meisten vorherigen Versionen habe ich dies nicht beachtet. Vor allem habe ich als Admin jeden Artikel veröffentlicht ohne Ihn einem User zuzuordnen. Das war mein essentieller Fehler. Während in der normalen Joomla 1.6 Installation dies fast keine Rolle spielt, so ist es in der multilingualen Einstellung absolut tödlich. Am Besten ihr gewöhnt euch an so sauber wie nur irgendwie möglich zu arbeiten. Denn wie ich vorhin geschrieben habe, hat diese Nachlässigkeit bei mir in der standard Installation schon dazu geführt, dass einzelne Templates im Front-end komisch aussahen. Wenn ihr plant eure Installation schon vor Joomfish auf Mehrsprachigkeit umzustellen, dann kann ich euch das offizielle “Language Switcher Tutorial” empfehlen.

Und für alle die interessiert wie man in dem riesen System darauf kommt, das eine Verlinkung fehlt, dem möchte ich hier noch die ganze Geschichte schildern.

Meine Blogeinträge werden grundsätzlich auch auf meine Facebookseiten gespiegelt. Dort kam mir mein alter Kollege Mario www.diedenker.com zur Hilfe und hat mir seinen Freund Manfred von www.zielwasser.eu vorgestellt. Meine Email war kaum ne Stunde weg, da hat sich Manfred auch gleich bei mir gemeldet. Mit einem Testaccount habe ich Ihn dann auf meine Seite gelassen wo er binnen weniger Minuten den ganzen Fehler wiederlegte. Ich konnte es kaum glauben. Er hat Artikel angelegt, die mit Kategorien verlinkt und das Menü erstellt. Alles funktionierte hervorragend. Als ich das gesehen habe, war es mir fast peinlich so einen Aufwand betrieben zu haben. Wir haben nur kurz telefoniert wobei mir Manfred als erfahrener Joomla Nutzer die entscheidenden Hinweis gegeben hat und mich darin bestärkte, dass es eigentlich nur was ganz kleines sein kann.

Mit einem funktionierenden Menüstrang habe ich mich dann auf die Suche gemacht und Manfreds Einträge langsam so verändert das Sie identisch mit meinen defekten waren. Ich konnte machen was ich wollte, die Einträge waren vorhanden. Meine leider nicht. Als letztes habe ich dann jeden einzelnen Bestandteil verglichen und bin so schließlich drauf gekommen, dasd es nur am Benutzer bzw. der Benutzerzuordnung liegen kann. Testhalber noch schnell ein paar alte Artikel auf den Testzugang geschrieben, dann war die Sache klar und ich konnte Manfred freudestrahlend Feedback geben. Das ganze war ein Zusammenspiel von Glück, guten Freunden, und einem hilfsbereiten Menschen. Jeder nicht Onliner denkt jetzt sicher ob ich noch alle beieinander habe mich so über ne funktionierende Webseite zu freuen. Diejenigen die täglich Webseiten bauen und programmieren können aber wahrscheinlich mein Wellenbad der Gefühle nachvollziehe.

Hier noch ein paar Informationen zu der ganzen Aktion:

Joomla habe ich vor 5 Tagen von 1.5 auf 1.6 mittels jUpgrad umgebaut. Ich kann jUpgrad soweit empfehlen, als das man schon Ahnung von Joomla haben muss. Vor allem aber dann wenn es darum geht die alte Installation sauber aus den Datenbanken zu löschen und alte Plugind und Komponenten unwirksam zu machen oder ebenfalls zu löschen. Wer sich nicht sicher ist, sollte auf jeden Fall das ganze erst mal testhalber über eine Backupinstallation laufen lassen.

Mit dem ganzen Stress habe ich meine Freundin wohl mehr als einmal zur Weißglut gebracht. Wie gesagt ich bin ein “Extrem heavy Onliner”. Da muss Sie durch. Zwinkerndes Smiley

Als Template verwende ich “Dreamsquare” von www.vonfio.de . Das Template funktioniert sauber und gut. Ich muss allerdings noch ein wenig daran rumbasteln bis es auch sauber auf Safari läuft. Das könnte dann mein nächster Blogeintrag werden. Meine Webseite findet ihr unter www.hendric-doeggingen.de.

websitejoomla1

Nachtrag – Erfahrung eines Lesers (17.08.2012):  Dieser Beitrag scheint relativ häufig aufgerufen zu werden. Dabei kommt es immer wieder zu verschiedenen Fragen und vor allem zu völlig unterschiedlichen Fehlerbildern. Vor wenigen Tagen berichtete mir ein Leser, dass er beim Upgrade mittels jUpgrade den Fehler hatte, dass Berichte anschließend nicht mehr angezeigt werden. Nach längerem Suchen viel dann auf, dass die Berichte auf einmal unveröffentlicht waren. Beim einloggen im Frontend waren die Berichte wohl mit dem Vermerk „unveröffentlicht zu sehen“. Im Backend jedoch standen Sie auf „veröffentlicht“. Der Leser hat dies dann über das Frontend mittels „editieren“ gelöst und von dort die Artikel neu veröffentlicht. Anschließend funktionierte alles.  Danke Flo für dein Beispiel.

Hilfe!- Wer kennt sich mit Joomla 1.6 schon sehr gut aus?

Hei Leute,
auf meiner Seite möchte ich im Bereich „Bilder und Berichte“ alle Beiträge der Kategorie „Galerien Hauptseite“ als Liste anzeigen. Dies hatte ich in der vorherigen 1.5 Installation auch so. Die Beiträge sind alle vorhanden und auf Deutsch gestellt, genauso wie die Kategorie selbst auch.
Im Menü wird folgender Link generiert: http://www.hwws.de/de/bilder-und-galerien.html

Dieser zeigt auch die Kategorie Beschreibung an. Anschließend sagt er jedoch das in dieser Kategorie keine Beiträge vorhanden sind.
Das stimmt nicht. Insgesamt habe ich 16 Beiträge dort hinterlegt.
Hier einige Beispiele: Reisebericht1, Reisebericht2,
Ich weiß mir nicht mehr zu helfen. Ich habe schon versucht neue Kategorien zu erstellen, neue Beiträge zu erstellen, neue Menüeinträge usw.
Des Weiteren habe ich das ganze mit anderen Templates, inklusive des standard templates versucht. Das gleiche dann auch jeweils in unterschiedlichen Sprachbereichen. Im Bereich Optionen, habe ich sowohl unter Listen Layout als auch unter Kategorien und Kategorie alles auf anzeigen. Auch die Kategorie-levels sind offen und ohne Beschränkung. Meine Levels gehen nicht tiefer als 3.
Hier ist übrigens noch der Link zur Überkategorie „Bilder“ die zeigt das Beiträge in jeder Unterkategrie vorhanden sind.

Also wie oben schon beschrieben, Ich hab keine Ahnung was man noch tun kann. Hoffe auf eure Hilfe. Achso und noch wass, bitte keine Posts mit „Never change a running system“. Das weiß ich auch. Aber der Reiz war halt stärker.